请选择 进入手机版 | 继续访问电脑版
12
返回列表 发新帖
楼主: xujw

[求助] 急急急!1052 Jlink连接不上(Jflash连接不上)

[复制链接]
  • TA的每日心情
    慵懒
    前天 00:48
  • 签到天数: 188 天

    [LV.7]常住居民III

    11

    主题

    486

    帖子

    29

    金豆

    金牌会员

    Rank: 6Rank: 6

    积分
    2771
    最后登录
    2021-4-12
    发表于 2021-4-1 09:48:35 | 显示全部楼层
    Jlink发现不了多半是硬件电路问题了,建议再检查一下。boot_mode默认是啥有啥影响吗。。。。我印象中需要一个0一个1才能从flash启动。
    该会员没有填写今日想说内容.
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    9

    主题

    35

    帖子

    0

    金豆

    注册会员

    Rank: 2

    积分
    127
    最后登录
    2021-4-2
    发表于 2021-4-1 09:58:09 | 显示全部楼层
    有一个管脚配置JTAG还是SW接口的,接电阻了吗?
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    开心
    2021-3-29 16:57
  • 签到天数: 1 天

    [LV.1]初来乍到

    1

    主题

    12

    帖子

    0

    金豆

    注册会员

    Rank: 2

    积分
    51
    最后登录
    2021-4-8
     楼主| 发表于 2021-4-1 13:57:01 | 显示全部楼层
    huangxuejia-292 发表于 2021-4-1 09:58
    有一个管脚配置JTAG还是SW接口的,接电阻了吗?

    那个管脚哇?
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    9

    主题

    35

    帖子

    0

    金豆

    注册会员

    Rank: 2

    积分
    127
    最后登录
    2021-4-2
    发表于 2021-4-1 15:05:10 | 显示全部楼层
    RT1052是F13,
    回复 支持 反对

    使用道具 举报

    该用户从未签到

    349

    主题

    5543

    帖子

    0

    金豆

    超级版主

    Rank: 8Rank: 8

    积分
    10508
    最后登录
    2021-4-12
    发表于 2021-4-2 12:33:58 | 显示全部楼层
    xujw 发表于 2021-3-31 16:52
    悬空的,boot_mode默认的是高电平还是低电平?

    应该是弱上拉,设计的时候没有是悬空的
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    开心
    2021-3-29 16:57
  • 签到天数: 1 天

    [LV.1]初来乍到

    1

    主题

    12

    帖子

    0

    金豆

    注册会员

    Rank: 2

    积分
    51
    最后登录
    2021-4-8
     楼主| 发表于 5 天前 | 显示全部楼层

    谢谢指导!复用了BOOT_CFG1[7:4],现在是将这4pin下拉后,Jlink可以连接上去!
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    开心
    2021-3-29 16:57
  • 签到天数: 1 天

    [LV.1]初来乍到

    1

    主题

    12

    帖子

    0

    金豆

    注册会员

    Rank: 2

    积分
    51
    最后登录
    2021-4-8
     楼主| 发表于 5 天前 | 显示全部楼层
    小恩GG 发表于 2021-4-2 12:33
    应该是弱上拉,设计的时候没有是悬空的

    复用了BOOT_CFG1[7:4],现在是将这4pin下拉后,Jlink可以连接上去!通过Jlink读取到boot-mode的寄存器两位是0,即从串口启动;请问芯片串口1的电平和波特率分别是多少吗?想通过串口或者Jlink修改eFuse让boot跳到从外部nor flash启动,同问能否通过Jlink写eFuse?望指教,谢谢!
    回复 支持 反对

    使用道具 举报

  • TA的每日心情
    开心
    2021-3-29 16:57
  • 签到天数: 1 天

    [LV.1]初来乍到

    1

    主题

    12

    帖子

    0

    金豆

    注册会员

    Rank: 2

    积分
    51
    最后登录
    2021-4-8
     楼主| 发表于 5 天前 | 显示全部楼层
    az158 发表于 2021-4-1 09:48
    Jlink发现不了多半是硬件电路问题了,建议再检查一下。boot_mode默认是啥有啥影响吗。。。。我印象中需要 ...

    谢谢回复!复用了BOOT_CFG1[7:4],现在是将这4pin下拉后,Jlink可以连接上去!
    回复 支持 反对

    使用道具 举报

    您需要登录后才可以回帖 注册/登录

    本版积分规则

    关闭

    站长推荐上一条 /2 下一条

    Archiver|手机版|小黑屋|恩智浦技术社区

    GMT+8, 2021-4-13 04:10 , Processed in 0.069449 second(s), 18 queries , MemCache On.

    Powered by Discuz! X3.4

    Copyright © 2001-2020, Tencent Cloud.

    快速回复 返回顶部 返回列表